As stated previously, resizing a FreeBSD filesystem (read: UFS2) might by a bit tricky. At least on FreeBSD 9.2 this isn't true anymore. To resize a UFS filesystem:
$ camcontrol rescan all
$ gpart showIf this doesn't show the correct size for the resized device, then reboot. During reboot ignore any warnings about invalid GPT headers
$ gpart recover ada0
$ sysctl -w kern.geom.debugflags=16
$ gpart resize -i 3 ada0
$ growfs ada0p3Enter Yes (case-sensitive!) when asked
$ sysctl -w kern.geom.debugflags=0
This even works for a mounted root filesystem.